Lo, I am blocked

27 06 2007

So I frequently park myself at the local Panera to partake of their free wireless, tasty coffee, and comfy chairs. It’s also convenient that it’s halfway between home and my son’s school.
Yesterday, I stopped by just to get out of the heat. Since I had an hour to kill, I worked up my last blog post, put it together and posted it. So far so good. I traditionally look at the site at it’s base URL (http://planet-geek.com/) just to make sure everything is okay. This time, apparently everything was NOT okay.
Apparently access to my blog has been blocked by the infamous Sonicwall ‘content protection’ system. Nice of them, eh?
Further research into this problem, by following their url, showed that I was not blocked for my abysmal spelling, my poor site layout, or my lack of meaningful content, but that I was simply classified as… pornography.
I had no idea geekitude had slipped so far into the internet’s dark underworld.
Naturally, I immediately put in a request to have it reclassified, and demanded an explanation as to WHY my little corner of geekness has been classified as Pornography. Alas, Sonicwall doesn’t provide such information, you may simply ask for a reclassification, and they might get around to it. In 8-10 days. What do you bet that I won’t hear a thing from them in that timeframe?
If you’d like to grease the wheels against this idiocy, please go to Sonicwalls’ ratings page, look up ‘planet-geek.com’, and request to have it reclassified as an “Information Technology” website.
I still would very much like to hear from Sonicwall, or from anyone else, who has had their site randomly excluded from anyone who uses their product, with no notification and no recourse except for a ‘request for reclassification’, why this occurs and what can be done about it. I’d also recommend that ANYONE who hosts or runs a website to plug their URL into that page and check to see if they’re being blocked.





Tooltrays. Why did it have to be tooltrays?

26 06 2007

Seems simple enough. Put an icon in the tooltray to notify you when ther eare updates for your OS. Ubuntu and others have outstanding package management, this is just the next step.
Oh look, it’s showing me a ! – must be updates. *double-click*
Bzzt, bad UI experience! 10yd penalty! Click once, get the “please type your password”. Double click? You get TWO “please type your password” dialog boxes.
There’s a serious level of inconsistency in tooltray management on Linux desktops. I suspect some of it comes from the slow convergence of KDE and Gnome based tools, each having ‘their own way’ of doing things, but I have no baseline from which to make a safe assumption about what to do with a tooltray icon. Do I double-click it? Single? Right click? Each application is different.
So close! 🙂





Zach and a harbor seal.

23 06 2007



P6230256

Originally uploaded by eidolon

Zach and I took an hour or so to swing by the aquarium yesterday after a a nice long bike ride around Dorchester.

The harbor seals were as charming as ever. This one even hung around for a photo with Zach!





Updating Jarindex

20 06 2007

Grump. I had no idea, but Jarindex was not working at all. Searches were coming up blank. Frustrating, when it’s supposed to be a handy search tool for finding classes in the vast swampland of Jar files out on the net.
Anyway, I fixed the indexer, and loaded up Hibernate 3.2 and Jboss 4.2.0 into it. Probably should update other packages as well. Currently I have:

apache-ant-1.6.5 eclipse-SDK-3.1.2 jakarta-oro-2.0.8 jboss-4.0.2 jdk1.5.0_04 jetty-5.1.10 junit3.8.1 OROMatcher-1.1.0a velocity-1.4
axis2 hibernate-3.2 jakarta-slide-webdavclient-bin-2.1 jboss-4.2.0.GA jdom-1.0 jpcap-0.01.16-win32 lps-3.1.1 rss_utils_1.1 velocity-tools-1.2

If any Java geeks want to see other packages loaded into it, let me know.





Cool power supply hack!

19 06 2007

This is pretty durned neat. I use a standard bench power supply when doing geektinkering. It has a dial for 9v, 12v, etc, and has the normal banana-posts for connecting up power leads.
Some bright folks noted that PC power supplies, which are a dime a dozen, are +/- 5v and +/- 12v already. Why not just scavenge a power supply, put contacts on it, and use it as your bench PS?
Just like this.
I have to try this!
(Special thanks to Hack-a-day for the link.)





JBoss Release Grumpiness

18 06 2007

This is a geek gripe. Particularly for Java programmers. If you’re not doing JEE development, this probably won’t make a lot of sense unless you like seeing open source companies being beaten up for version incompatibilities.
Hello, I’m Dave, and I’m a JBoss developer. (Hi Dave…)
Until recently, I was quite content with the series of tools available for JBoss4, and my chosen IDE, Eclipse. JBoss provided a lovely little plugin interface called JBoss IDE. I encourage people to click on that link, because you’ll walk through a series of redirects until you land on a page that, amazingly, has no information on where to get JBoss IDE! How wonderful!
It turns out that JBoss (now wholly owned by Redhat has pulled JBoss IDE in favor of another Eclipse plugin called Exadel. Fantastic, a new IDE plugin that has a lot more functionality than JBoss-IDE ever had. Lets take a look!
An hour later, and Exadel is installed and running and grand. But. Wait a moment, the latest version of the JBoss application server is 4.2-GA. That’s General Availability. Meaning the platform is released and is the recommended system for users.
Exadel has no configuration support for 4.2-GA. Only for 4.0.x releases.
And JBoss-IDE has been pulled completely (and even it’s ‘2.0.0-beta’ version, the most recent version they posted, did not support 4.2).
“Must be coming out shortly.” So I mailed off to Exadel tech support asking if there was 4.2 support in the works, or when it will come out.
I get a direct, and undeniable response from them:

Dave Belfer-Shevett wrote:
> > Exadel Support Team wrote:
>> > > Exadel Studio Pro is going to be re branded as Red Hat Developer Studio in
>> > > later summer. Red Hat Developer Studio will support JBoss 4.2 .
> >
> > So the answer is “no, it does not support 4.2 now, and won’t until late
> > summer” ?
That’s correct.
-The Exadel Team

Excuse me, but WHAT THE F??? We’ve pulled the old IDE toolset. We’ve released a new product. But you CAN’T USE IT WITH OUR IDE TOOLS! Hahahahha! And you won’t for a couple months. Sorry bout that, have a nice day.
There are workarounds. You can run the jboss server externally in a windows shell and deploy to it. This is a painful arrangement, but I guess I have no choice?
Thanks for leaving us all in the lurch, JBoss.





Rampant Eye Candy

10 06 2007

It’s about time I did something with some of this horsepower on my desk. So this week I fired up a couple toys just to have some fun.

Read the rest of this entry »